venerdì 31 agosto 2012

E anche il motore se ne è andato....


Non so come mai, ma ultimamente scrivo sul Blog cose negative....

Speriamo che passi presto questo tormento, ma penso che la disgrazia di oggi sia in parte collegata all'incidende a cui faccio riferimento proprio nel post precedente.
Cosa è successo? Dopo aver percorso circa due o tre Km lo scooter ha iniziato ad fare un brutto rumore al motore e pian piano perdeva potenza ed andava a strappi.
Poi riprendeva a funzionare per poi smettere ancora, man mano le cose andavono comunque peggiorando al punto che riuscivo a malapena ad arrivare a 10Kmh. Dato che la sfortuna non arriva mai da sola ovviamente ha iniziato a piovere, la felicità è arrivata allle stelle!!

Vabbe', ho chiamato un carro attrezzi per portare lo scooter al box di mio padre, poi abbiamo iniziato a fare qualche controllo giusto per escludere le prime cose:
Il BMS era innocente, lo abbiamo bypassato e il problema  c'era ancora

L'acceleratore era innocente,abbiamo misurato la tensione di uscita che effettivamente variava in funzione di quanto si girava la manopola

L'interruttore freni, anche questo puo' bloccare malamente il funzionamento, lo abbiamo sganciato del tutto.

Connessioni varie sono state controllate per vedere se il problema arrivava da li, ma niente ancora.

L'attenzione si è allora focalizzata su centralina e motore, come da copione e come ci si aspettava , il rumore e l'andare a strappi dipende da un problema di coordinamento tra gli impulsi della centralina e la posizione del mototre brushless fornita mediante gli hall sensor.
Uno degli hall sensor effettivamente non funzionava correttamente e mandava in crisi la centralina, una volta provveduto alla sostituzione con il motore smontato dallo scooter di backup (diciamo praticamente donato da un amico per la causa) , il mezzo ha ripreso a funzionare.
Ora ci si domanda come sia potuto essere possibile che dopo soli 17.000Km un hall sensor abbia potuto morire, ma riporto la testimonianza in modo che se a qualcun'altro dovesse succedere abbia una idea dei sintomi. Forse si è rovinato a causa dlla caduta di un mese fa, oppure dopo la riparazione di Giugno quando avevo bucato.

In teoria questi motori dovrebbero durare un sacco di tempo, ma la sfortuna è sempre dietro l'angolo.

11 commenti:

spuzzete ha detto...

Ciao Ccriss!
Sono contento che sei riuscito a riparare il motore!
I motori elettrici per veicoli sono ancora in evoluzione, io con l'Evt 4000e (parliamo di anni luce indietro in termini di motori elettrici per scooters) avevo ancora il motore a spazzole. Anche quello era sponsorizzato come motore "sicuro e senza manutenzione". Dopo qualche migliaia di km però le spazzole si sono consumate e la polvere di carbone (conduttiva ovviamente) è entrata nel motore..praticamente bruciandolo, assieme alla centralina.
Poi hanno preso piede i motori brushless con sensori di hall, come il tuo. Solo che se si bruciano o non funzionano i sensori succede quello che è successo a te. Esistono ora motori e centraline "sensorless" (probabiilmente lo sai anche tu, ma forse chi legge no) che a mio giudizio sono la migliore soluzione per l'affidabilità. I sensori di hall sono molto delicati, un sistema senza sensori è secondo me piu affidabile. Si dovrà di conseguenza "lavorare" di piu sulle centraline, ma mi pare che queste ultime siano in costante evoluzione. Comunque dai 17.000km non sono pochi! Tutti questi "inconvenienti" che ti stanno capitando saranno tutta esperienza per il tuo prossimo scooter/veicolo!

CCriss ha detto...

Quello che ti è successo sul motore con le spazzole era un problema che metteva davvero ansia!! Pensare che mentre vai si poteva fulminare tutto non era certo bello, poi se quelli che lo vendono ti dicono che è eterno...
Ho sentito parlare dei controller sensorless,ma sentivo anche dire che chi lo aveva provato lo trovava sulle partenze è un po' grezzo.
E' una alternativa da valutare quando il motore va in crisi a causa degli hall sensor invece che sostituirlo o ripararlo si passa alla controller sensorless:-)

spuzzete ha detto...

Si Ccriss, quando ho bruciato motore e centralina sull Evt sia io che mio padre non sapevamo che fare, alla fine abbiamo cambiato centralina e motore. Il motore "bruciato" ci avevano detto che poteva essere recuperato, ma chi si fidava a fare un test dopo quel che era successo?
Ad ogni modo hai ragione sui sensorless, il mio controller offre le 2 opzioni e quando vado sensorless "trema" in partenza da fermo ma a parte quello va benissimo.Calcolando che il mio è un controller da 25 dollari non mi posso assolutamente lamentare. Migliori controller come questo: http://www.electricrider.com/crystalyte/x-ct7240e.htm (costa anche 15 volte tanto ehehe) non dovrebbero avere questo problema. Come dici tu è saggio avere un controller sensorless di emergenza in casa in modo da poter usare ancora il mezzo mentre si aspettano i ricambi :)

CCriss ha detto...

Se puo' interessare ci sarebbe anche questa controller, 75A continuativi x 379$!!Unico problema è che la vendono pur essendo in beta version, strano vero?

http://kellycontroller.com/72v-sensorless-ksl-controllers-c-64_67.html

spuzzete ha detto...

Ho visto Criss, chissà che vuol dire "beta version", di certo non vorrei fare la cavia spendendo quasi 400$!Comunque è buono sapere che ci stanno lavorando sopra :) .

Alainros ha detto...

Mi dispiace per il motore :(
Il mio EJ quando parte da fermo innesca una vibrazione piuttosto rumorosa, quindi secondo voi dovrebbe montare un motore sensorless?

CCriss ha detto...

Alainros, intanto grazie per le "condoglianze"..
E' abbastanza improbabile che monti un sensorless per due motivi:
Il primo è che ad oggi costa di piu' di una centralina ordinaria, ma un domani penso che le cose cambieranno.
Il secondo è che non è ancora abbastanza affidabile e diffuso..
Per capirlo dovresti vedere quanti fili vanno dal motore alla centralina, le centraline ordinare hanno bisogno di almeno 8 fili (+5V, GND,3 fili di hall sensor +3 fili di "potenza" per far muovere il motore), se ce ne sono meno (dovrebbero essere 3/4 in meno) è un sensorless.

spuzzete ha detto...

Ciao Alainros,

descrivi un po' meglio il problema, potrebbe essere un cuscinetto o altro. Se un sensore di hall è staccato/bruciato hai quasi sicuramente problemi in partenza (e anche in marcia), il motore fatica a girare e funziona un po' a scatti. Se è solo una vibrazione probabilmente è qualcos'altro.
In ogni caso un motore con sensori di hall funziona anche in modalità "sensorless", è il controller/centralina ad occuparsi di come gestire la rotazione del motore.

Alainros ha detto...

@Spuzzete
Semplicemente quando parto da fermo il motore fa un specie di risonanza che fa rumore tipo una bici elettrica con hub motor che parte (o almeno la mia bici fa lo stesso rumore...) ma appena la ruota comincia a girare torna tutto silenziosissimo. Però non è che si sente lo scooter andare a scatti come quando è impostato male il timing sull'esc.
@CCriss
Se non ricordo male ho solo 3 grossi cavi che vanno al motore, comunque provo a chiedere

CCriss ha detto...

@Alain, l'effetto di cui parli in partenza ce l'ho anch'io ed è abbastanza normale, si tratta degli impulsi che manda la centralina al motore, quando sono fermo e do pochissimo gas posso sentire chiaramente gli impulsi. Parlando sui forum della controller sensorless direi che si puo' dire che è ancora presto per vederle montate sugli scooter dai produttori.

spuzzete ha detto...

@ Alainros, concordo con Ccriss, e ho lo stesso fenomeno sulla mia bici :)

@ Ccriss, oggi mi è arrivato il nuovo arduino. Sto tentando di migliorare le connessioni, alla fine quando tutto è definitivo voglio metterlo in una scatola sigillata. ho messo una foto qui https://twitter.com/jacopo_tk/status/245711257880125440/photo/1/large

Ora posso staccare lo screen dal resto. Ho usato un collegamento con un cavo ethernet.

Ho risolto con il sensore degli Amps, ora sembra che vada tutto ok.

L'unico problema è che c'è un certo delay nella trasmissione dei dati, capita anche a te? Forse è il mio codice troppo disordinato.